Contact Information
Forescout Technologies, Inc.
190 West Tasman Drive
San Jose, CA 95134 USA
https://www.Forescout.com/support/
Toll-Free (US): 1.866.377.8771
Tel (Intl): 1.408.213.3191
Support: 1.708.237.6591

About the Documentation
• Refer to the Technical Documentation page on the Forescout website for additional documentation: https://www.Forescout.com/company/technical-documentation/
• Have feedback or questions? Write to us at documentation@forescout.com

Legal Notice
© 2020 Forescout Technologies, Inc. All rights reserved. Forescout Technologies, Inc. is a Delaware corporation. A list of our trademarks and patents can be found at https://www.Forescout.com/company/legal/intellectual-property-patents-trademarks. Other brands, products, or service names may be trademarks or service marks of their respective owners.
# Table of Contents

**About the Syslog Plugin** ......................................................... 4  
Multiple Destination Syslog Server Support ........................................ 4  
Receiving Event Messages ................................................................ 4  
Sending Syslog Messages ................................................................ 5  
  Sending Forescout Event Messages .................................................. 5  
  Using Actions to Send Endpoint Messages ...................................... 5  

**Requirements** ........................................................................ 6  
Forescout Requirements .................................................................. 6  

**Configuration** ........................................................................ 6  
Select an Appliance to Configure .................................................... 6  
Send Events To ............................................................................. 7  
  Facility Values ............................................................................. 8  
  Severity Values ........................................................................... 9  
Syslog Triggers ............................................................................. 10  
  Including Header Information in All Message ................................. 10  
  Selecting Syslog Message Triggers .................................................. 11  
  NAC Events ................................................................................ 12  
  Threat Protection ......................................................................... 12  
  System Logs and Events ................................................................. 13  
  User Operations .......................................................................... 13  
  Operating System Messages .......................................................... 13  
Default Action Configuration ............................................................ 14  
Receive From ................................................................................ 14  
Certificate Management .................................................................. 16  
Verify That the Plugin Is Running ..................................................... 16  
Testing the Plugin Configuration ....................................................... 16  

**Downloading and Configuring NTSyslog** .................................. 17  

**Create Custom Syslog Policies** ............................................... 20  
Send Message to Syslog Action ...................................................... 21  
Working with Property Tags ............................................................ 22  

**Core Extensions Module Information** ...................................... 23  

**Additional Forescout Documentation** ....................................... 23  
  Documentation Downloads ............................................................. 23  
  Documentation Portal ................................................................... 24  
  Forescout Help Tools .................................................................... 24
About the Syslog Plugin

The Syslog Plugin is a component of the Forescout® Core Extensions Module. See Core Extensions Module Information for details about the module.

The Syslog Plugin lets you send, receive and format messages to and from external Syslog servers. You can configure each Forescout device to:

- Send all event messages to one or more Syslog servers.
- Receive messages from up to three manually configured Syslog servers.

Multiple Destination Syslog Server Support

The following diagram provides an example of communication from Forescout devices to Syslog servers.

Receiving Event Messages

Receiving event messages from external Syslog servers allows the Forescout platform to gain visibility into events that cannot be obtained from analyzing traffic either because:

- Traffic is not visible to any of the deployed Forescout Appliances.
- Traffic is encrypted.
Login events are recorded on Windows Domain Controllers. When these events are received by the Syslog Plugin, the Forescout platform knows immediately if an endpoint has been authenticated to the Domain Controller and which User and Domain Name were used for authentication. The Forescout platform parses the received messages, and updates the relevant host properties. This information is displayed in the Profile tab of the Console Home view.

To receive messages from external Syslog servers, configure the Receive From plugin configuration tab.

### Sending Syslog Messages

Sending valuable information from the Forescout platform to one or more external Syslog servers allows the information to be used for event aggregation, auditing, and further processing. For a description of the contents of the different Syslog message types generated by the Forescout platform, refer to Forescout Technical Notes: *Syslog Messages Sent by Forescout*. See [Additional Forescout Documentation](#) for information about accessing this document.

There are two types of messages that you can send to Syslog:

- **Sending Forescout Event Messages**
- **Using Actions to Send Endpoint Messages**

### Sending Forescout Event Messages

You can configure the plugin to send ongoing messages about Forescout system events from one Forescout device to one or more Syslog servers using the configuration settings in the Syslog Plugin. See [Configuration](#).

Each Forescout device receives unique event information from the network, and will only send events to Syslog that occurred within the network segment of the Forescout device. This is important to consider when configuring which Forescout devices send messages to Syslog servers.

The Forescout platform can be configured to send a message to the configured Syslog servers each time a new event of the following type occurs:

- **NAC Events**
- **Threat Protection**
- **System Logs and Events**
- **User Operations**
- **Operating System Messages**

### Using Actions to Send Endpoint Messages

You can send customized messages to Syslog for specific endpoints using the Forescout eyeSight Send Message to Syslog action, either manually or in Forescout platform policies. Use the action to send messages based on policy results or at customizable intervals. See [Send Message to Syslog Action](#).
Requirements

This section provides the requirements for configuring and running the Forescout Syslog Plugin.

- Forescout Requirements

Forescout Requirements

The following Forescout platform and component versions must be running in your Enterprise Manager and your Appliances:

- Forescout 8.2
- Core Extensions Module 1.2 with the Syslog Plugin

Configuration

This section describes how to configure the Syslog Plugin.

Select an Appliance to Configure

This section describes how to configure the plugin to ensure that the Forescout device can properly communicate with Syslog servers.

To configure the Syslog Plugin:

1. In the Modules pane, select **Core Extensions > Syslog** and then select **Appliances**. The **Syslog - Appliances Installed** dialog box opens.

2. Select any Appliance or the Enterprise Manager and select **Configure**. You cannot configure multiple Forescout devices simultaneously. The **Configuration** dialog box opens.
3. See the following sections to complete the information in each tab:
   - **Send Events To**
   - **Syslog Triggers**
   - **Default Action Configuration**
   - **Receive From**

4. When the configuration is complete, select **OK**.

**Send Events To**

The *Send Events To* tab lists the Syslog servers to which the Forescout device will send messages regarding the event types selected in the *Syslog Triggers* tab. For each Syslog server, define:

- The details that the Forescout platform needs to communicate with the server
- The *Facility*, *Severity*, and *Message Identity* values to be included in all event messages
To configure the Forescout platform to send event messages to Syslog servers:

1. In the Send Events To tab, do one of the following:
   - To define a Syslog server not in the table, select Add.
   - To modify the definition of an existing server, select it in the table and select Edit.

2. Specify the following information for the server:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Address</td>
<td>Syslog server IP address or fully qualified domain name (FQDN).</td>
</tr>
<tr>
<td>Server Port</td>
<td>Syslog server port.</td>
</tr>
<tr>
<td>Server Protocol</td>
<td>Syslog messaging can use TCP or UDP. Select the protocol to be used for communicating with this Syslog server.</td>
</tr>
<tr>
<td>Use TLS</td>
<td>For some server types, you can instruct the Forescout platform to use TLS to encrypt communication with the Syslog server.</td>
</tr>
<tr>
<td>Soft-fail OCSP Requests</td>
<td>If the Forescout platform could not receive a response from the OCSP Responder, the certificate is considered valid. By default, hard-fail is applied. In order to use this option, you must also enable the Use TLS option.</td>
</tr>
<tr>
<td>Message Identity</td>
<td>Free-text field for identifying the Syslog message.</td>
</tr>
<tr>
<td>Facility</td>
<td>Syslog message facility that is transmitted as part of the message Priority field. For valid values, see Facility Values.</td>
</tr>
<tr>
<td>Severity</td>
<td>Syslog message severity that is transmitted as part of the message Priority field. For valid values, see Severity Values.</td>
</tr>
</tbody>
</table>

3. Select OK. The updated server definition appears in the table.

4. (Optional) To delete a server, select it in the table and select Remove.

For the certificates required when using Send Events To Syslog servers, see Certificate Management.

Facility Values

The Syslog message facility must be one of the values in the following table:

<table>
<thead>
<tr>
<th>Facility Value</th>
<th>IETF Facility Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>kern</td>
<td>kernel messages</td>
</tr>
<tr>
<td>kernel</td>
<td>kernel messages</td>
</tr>
<tr>
<td>user</td>
<td>user-level messages</td>
</tr>
</tbody>
</table>
Facility Value | IETF Facility Description
--- | ---
mail | mail system
daemon | system daemons
system | 
auth | security/authorization messages
syslog | messages generated internally by syslog
internal | 
lpr | line printer subsystem
printer | 
news | network news subsystem
uucp | UUCP subsystem
cron | clock daemon
clock | 
authpriv | security/authorization messages
security2 | 
ftp | 
FTP | 
NTP | NTP subsystem
audit | log audit
alert | log alert
clock2 | clock daemon
local0 | local use 0
local1 | local use 1
local2 | local use 2
local3 | local use 3
local4 | local use 4
local5 | local use 5
local6 | local use 6
local7 | local use 7

If the facility value is not valid, it is set to local5.

Severity Values

The Syslog message severity must be one of the values in the following table:

Severity Value | IETF Severity Description
--- | ---
emergency | system is unusable
emerg |  
<table>
<thead>
<tr>
<th>Severity Value</th>
<th>IETF Severity Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>alert</td>
<td>action must be taken immediately</td>
</tr>
<tr>
<td>critical</td>
<td>critical conditions</td>
</tr>
<tr>
<td>crit</td>
<td>critical conditions</td>
</tr>
<tr>
<td>error</td>
<td>error conditions</td>
</tr>
<tr>
<td>err</td>
<td>error conditions</td>
</tr>
<tr>
<td>warning</td>
<td>warning conditions</td>
</tr>
<tr>
<td>notice</td>
<td>normal but significant condition</td>
</tr>
<tr>
<td>informational</td>
<td>informational messages</td>
</tr>
<tr>
<td>info</td>
<td>informational messages</td>
</tr>
<tr>
<td>debug</td>
<td>debug-level messages</td>
</tr>
</tbody>
</table>

If the severity value is not valid, it is set to **error**.

**Syslog Triggers**
Configure the settings in the *Syslog Triggers* tab.

**Including Header Information in All Message**
The *Syslog Triggers* tab contains a setting that applies to all Syslog messages sent from the Forescout device.

Select **Include timestamp and CounterACT device identifier in all messages** to include in all Syslog messages:

- A timestamp
- The device name or IP address of the Forescout device sending the message

*If Device Name is selected but cannot be resolved, the Forescout device IP address is included in its place.*

These fields comply with the RFC 3164 specification for BSD Syslog.
Selecting Syslog Message Triggers

Syslog messages can be generated by Forescout platform policies when endpoints meet conditional criteria.

To enable Syslog messages to be generated by events and not only by policies, the Include only messages generated by the "Send Message to Syslog" action checkbox must not be selected.

If the Include only messages generated by the "Send Message to Syslog" action checkbox is not selected, you can select options in the tab to define which event types trigger Syslog messages.

You can select event triggers from the following categories:

- NAC Events
- Threat Protection
- System Logs and Events
- User Operations
- Operating System Messages
### NAC Events

These event messages contain information on all policy event logs.

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAC policy logs</td>
<td>Endpoint policy events. The log displays information about endpoints as they are detected and is continuously updated as the policy is evaluated for the endpoint.</td>
</tr>
<tr>
<td>NAC policy match/unmatch events</td>
<td>Policy evaluation change events.</td>
</tr>
</tbody>
</table>

### Threat Protection

These event messages contain information on intrusion-related activity, including bite events, scan events, lockdown events and manual events. These messages can be triggered when the Syslog Plugin runs on an Appliance but not when it runs on an Enterprise Manager.

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bite events</td>
<td>Indicates that an endpoint has tried to gain access to your network using a system mark.</td>
</tr>
</tbody>
</table>
## Scan events
Indicates that an endpoint has performed a specific probe a defined number of times within a defined time period. By default, when an endpoint initiates three probes within one day, the Forescout platform considers this activity a scan.

## Lockdown events
Indicates that a malicious event has been detected by another Appliance.

## Block events
Indicates that the Forescout platform has blocked packets from the source from going through to the specified destination (host + service).

## Email worm events
Indicates that the Forescout platform has identified email worm anomalies sent over email.

### System Logs and Events
These event messages contain information about the Forescout platform system events.

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System uptime events</td>
<td>Indicates the amount of time the Forescout service has been running.</td>
</tr>
<tr>
<td>System log events</td>
<td>Indicates certain Forescout platform activities detected by the system. For example, successful and failed user login operations. (Messages sent to the Event Viewer)</td>
</tr>
<tr>
<td>System status messages</td>
<td>Indicates memory, swap and CPU usage statistics.</td>
</tr>
<tr>
<td>Packet Engine status messages</td>
<td>Indicates the status of the Forescout service that monitors and injects SPAN port traffic. If it is down, many Forescout features will not work.</td>
</tr>
</tbody>
</table>

### User Operations
These event messages are generated when a user operation takes place, and they are included in the Audit Trail.

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User operations</td>
<td>Indicates that the user made a configuration change such as updating policies, stopping or starting the device, or updating user passwords.</td>
</tr>
</tbody>
</table>

### Operating System Messages
These event messages are generated by the operating system.

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system messages</td>
<td>Indicates an event of relevance at the level of the operating system. This is useful, for example, if you want to monitor the health of an Appliance or Enterprise Manager by sending the events to a SIEM.</td>
</tr>
</tbody>
</table>
**Default Action Configuration**

The *Default Action Configuration* tab allows you to define default values for the *Send Message to Syslog* action parameters. These default values are applied to parameters that are not defined in policies. See [Send Message to Syslog Action](#) for details.

Specify the following values:

<table>
<thead>
<tr>
<th><strong>Field</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Address</td>
<td>Syslog server IP address or fully qualified domain name.</td>
</tr>
<tr>
<td>Server Port</td>
<td>Syslog server port.</td>
</tr>
<tr>
<td>Server Protocol</td>
<td>Syslog messaging can use TCP or UDP. Select the protocol to be used for communicating with this server.</td>
</tr>
<tr>
<td>Message Identity</td>
<td>Free-text field for identifying the Syslog message.</td>
</tr>
<tr>
<td>Facility</td>
<td>Syslog message facility that is transmitted as part of the message Priority field. For valid values, see <a href="#">Facility Values</a>.</td>
</tr>
<tr>
<td>Severity</td>
<td>Syslog message severity that is transmitted as part of the message Priority field. For valid values, see <a href="#">Severity Values</a>.</td>
</tr>
</tbody>
</table>

**Receive From**

The *Receive From* tab allows you to define:

- Up to three Syslog agents from which the plugin may receive Syslog messages.
- Which ports the plugin will use to listen for messages being sent from the defined Syslog agents.
For each Syslog agent, define its Source Type and its IP Address. Currently, the only source type supported is NTSyslog security log. You must download and configure NTSyslog on an organizational domain controller to work with the Receive From feature. See Downloading and Configuring NTSyslog.

- Received messages are not stored by the Forescout platform.

**To configure Syslog sources:**

1. Per Syslog source, define the following:
   a. In the Source Type field, select **NTSyslog security log** from the dropdown menu.
   b. In the IP Address field, enter the IP address or fully qualified domain name (FQDN) of the domain controller.

2. In the Ports for Incoming Syslog Messages section, define either one or both of the following:
   a. In the **UDP Port** field, enter the UDP port that is used for listening for incoming Syslog messages. By default, **UDP Port** is set to 514.
   b. In the **TCP Port** field, enter the TCP port that is used for listening for incoming Syslog messages. By default, **TCP Port** is set to 0 and is not used.

- A port is not used for listening for incoming Syslog messages, when its value is set to 0.
3. Enable the **Use TLS** option to instruct the Forescout platform to use TLS to encrypt communication with the Syslog sources. By default, this option is disabled.

For the certificates required when using **Receive From** Syslog servers, see [Certificate Management](#).

## Certificate Management

When the Syslog Plugin is configured to use TLS to establish secure communication connections for the following use cases, you must define certificates:

- The plugin is configured to **Send Events To** Syslog servers, define each Syslog server's trusted certificate chain
- The plugin is configured to **Receive From** Syslog server sources, define the system certificate for the Syslog Plugin to present to each sender source
- For the plugin to apply the **Send Message to Syslog** action, define the targeted Syslog server's trusted certificate chain

Use the Console certificate interface to:

- Define and provision the system certificate for plugin presentation to each external, sender source for validation of the certificate. In the Console, access **Options > Certificates > System Certificates**.
- Configure the certificate authority (CA) trust chain of each external server for plugin authentication of these servers. In the Console, access **Options > Certificates > Trusted Certificates**.

In the *Forescout Administration Guide*, refer to the appendix titled *Configuring the Certificate Interface* for information about working with the Console certificate interface. See [Additional Forescout Documentation](#) for information on how to access this guide.

## Verify That the Plugin Is Running

After configuring the plugin, verify that it is running.

**To verify:**

1. Select **Tools > Options** and then select **Modules**.
2. Navigate to the plugin and select **Start** if the plugin is not running.

## Testing the Plugin Configuration

Use the test option to verify that the Forescout platform can communicate with the Syslog servers defined in the plugin configuration **Send Events To** tab.
To test the plugin configuration:

1. In the Modules pane, select Core Extensions > Syslog and then select Test. A confirmation message appears identifying Forescout devices on which the test will be performed.

2. Select Yes to begin the plugin test. The Plugin Test dialog box displays information about each Forescout device tested, as well as a number of test messages.

3. Verify that the Syslog servers received the messages displayed in the dialog box.

Downloading and Configuring NTSyslog

NTSyslog is a tool that sends Active Directory security logs to the Forescout platform if the Syslog Plugin is configured to receive messages. See Receive From to configure the plugin to receive messages.

To download and configure NTSyslog:

1. Install NTSyslog to your organizational Domain Controller. Use http://sourceforge.net/projects/ntsystool/ or download from another location.
2. Open the **NTSyslog Service Control Manager**.

![NTSyslog Service Control Manager](image1.png)

3. Select **Syslog Daemons**.

![Syslog Server Settings](image2.png)
4. In the *Primary Syslog Daemon* field, enter the IP address of the Forescout device to which traffic must be sent, and select **OK**.

5. In the NTSyslog Service Control Manager *EventLog* dropdown menu, select **Security**, and then select **EventLog**. Ensure that all events are selected.

6. Select **OK**.
7. Select **Start Service**, and verify that the *Service is running* message appears in the *NTSyslog Service Manager* dialog box.

![NTSyslog Service Control Manager](image)

**Create Custom Syslog Policies**

Policy tools provide you with an extensive range of options for detecting and handling endpoints. You can use a policy to instruct the Forescout platform to apply the **Send Message to Syslog Action** to endpoints that match conditions based on reported endpoint properties.

**To create a custom policy:**

1. **Log in** to the Forescout Console.
2. **On the Console toolbar**, select the **Policy** tab. The **Policy Manager** opens.
3. **Select Add** to create a policy.

   *For more information about working with policies, select **Help** from the policy wizard.*
**Send Message to Syslog Action**

Use the *Send Message to Syslog* action, grouped in the *Audit* category of actions, to send a Syslog message to an external Syslog server.

Specify the following configuration fields for the Syslog message, or accept the default values that were defined during plugin configuration. See Default Action Configuration.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Message to Syslog</strong></td>
<td>The text message that is sent to the Syslog server. You can use property tags to include endpoint data values. See Working with Property Tags.</td>
</tr>
<tr>
<td><strong>Message Identity</strong></td>
<td>Free-text field for identifying the Syslog message.</td>
</tr>
<tr>
<td><strong>Syslog Server Address</strong></td>
<td>Syslog server IP address or fully qualified domain name.</td>
</tr>
<tr>
<td><strong>Syslog Server Port</strong></td>
<td>Syslog UDP port number.</td>
</tr>
<tr>
<td><strong>Syslog Server Protocol</strong></td>
<td>Syslog messaging can use TCP or UDP. Select the protocol used to communicate with this server.</td>
</tr>
<tr>
<td><strong>Syslog Facility</strong></td>
<td>Syslog message facility that is transmitted as part of the message Priority field. For valid values, see Facility Values.</td>
</tr>
<tr>
<td><strong>Syslog Severity</strong></td>
<td>Syslog message severity that is transmitted as part of the message Priority field. For valid values, see Severity Values.</td>
</tr>
</tbody>
</table>
### Core Extensions Module: Syslog Plugin Configuration Guide

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use TLS</strong></td>
<td>For some server types, you can instruct the Forescout platform to use TLS to encrypt communication with the Syslog server.</td>
</tr>
<tr>
<td><strong>Soft-fail OCSP Requests</strong></td>
<td>If the Forescout platform could not receive a response from the OCSP Responder, the certificate is considered valid. By default, hard-fail is applied. In order to use this option, you must also enable the <strong>Use TLS</strong> option.</td>
</tr>
<tr>
<td><strong>Tags</strong></td>
<td>To add property tags, see <a href="#">Working with Property Tags</a>.</td>
</tr>
</tbody>
</table>

For the certificates required in order for the plugin to apply the *Send Message to Syslog* action, see [Certificate Management](#).

### Working with Property Tags

You can add current values of host properties to the message. Select **Add Tags** to insert a placeholder that is populated with the actual value of the host property when the message is generated.
Core Extensions Module Information

The Syslog Plugin is installed with the Forescout Core Extensions Module.

The Forescout Core Extensions Module provides an extensive range of capabilities that enhance the core Forescout solution. These capabilities enhance detection, classification, reporting, troubleshooting, and more. The following components are installed with the Core Extensions Module:

- Advanced Tools Plugin
- Device Data Publisher
- IoT Posture Assessment Engine
- CEF Plugin
- DNS Client Plugin
- NBT Scanner Plugin
- Cloud Uploader
- DNS Enforce Plugin
- Packet Engine
- DHCP Classifier Plugin
- DNS Query Extension Plugin
- Reports Plugin
- Dashboards Plugin
- External Classifier Plugin
- Technical Support Plugin
- Data Publisher
- Flow Analyzer Plugin
- Syslog Plugin
- Data Receiver
- Flow Collector
- Web Client Plugin
- Device Classification Engine
- IOC Scanner Plugin
- Technical Support Plugin
- Technical Support Plugin

The Core Extensions Module is a Forescout Base Module. Base Modules are delivered with each Forescout release. Upgrading the Forescout version or performing a clean installation installs this module automatically.

Additional Forescout Documentation

For information about other Forescout features and modules, refer to the following resources:

- Documentation Downloads
- Documentation Portal
- Forescout Help Tools

Documentation Downloads

Documentation downloads can be accessed from the Forescout Technical Documentation Page, and one of two Forescout portals, depending on which licensing mode your deployment is using.

- Per-Appliance Licensing Mode – Product Updates Portal
- Flexx Licensing Mode – Customer Support Portal

Software downloads are also available from these portals.

To identify your licensing mode:

- From the Console, select Help > About Forescout.
**Forescout Technical Documentation Page**

The Forescout Technical Documentation Page provides access to a searchable, web-based [Documentation Portal] as well as PDF links to the full range of technical documentation.

**To access the Technical Documentation Page:**
- Go to https://www.Forescout.com/company/technical-documentation/

**Product Updates Portal**

The Product Updates Portal provides links to Forescout version releases, Base and Content Modules, and eyeExtend products, as well as related documentation. The portal also provides a variety of additional documentation.

**To access the Product Updates Portal:**
- Go to https://updates.forescout.com/support/index.php?url=counteract and select the version you want to discover.

**Customer Support Portal**

The Downloads page on the Forescout Customer Support Portal provides links to purchased Forescout version releases, Base and Content Modules, and eyeExtend products, as well as related documentation. Software and related documentation will only appear on the Downloads page if you have a license entitlement for the software.

**To access documentation on the Customer Support Portal:**
- Go to https://Forescout.force.com/support/ and select Downloads.

**Documentation Portal**

The Forescout Documentation Portal is a searchable, web-based library containing information about Forescout tools, features, functionality, and integrations.

**To access the Documentation Portal:**
- Go to https://updates.forescout.com/support/files/counteract/docs_portal/

**Forescout Help Tools**

Access information directly from the Console.

**Console Help Buttons**

Use context sensitive Help buttons to quickly access information about the tasks and topics you are working with.

**Forescout Administration Guide**

- Select Administration Guide from the Help menu.
**Plugin Help Files**

- After the plugin is installed, select **Tools > Options > Modules**, select the plugin and then select **Help**.

**Documentation Portal**

- Select **Documentation Portal** from the **Help** menu to access the **Documentation Portal**.