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About the Plugin
The External Classifier Plugin is a component of the Forescout Core Extensions
Module. See Core Extensions Module Information for details about the module.
The External Classifier Plugin accesses a set of MAC addresses maintained in an FTP
server or an LDAP server to:


Assign a configured text label to any host whose MAC address matches a MAC
address in the retrieved set.



Use the assigned text label in a policy to follow up with required actions.

For example, a corporate finance printer, whose MAC address is 01:2b:45:6a:89:5F,
matches a MAC address in the set of MAC addresses that the plugin retrieved from a
remote FTP server. The plugin assigns a matching host the configured label
Inventory_NorthRegion_Printers. In the organization’s Primary Classification
policy, hosts whose label is found to match the string Printer are added to the group
(policy action) Corp_Equip_Printers and a notification of this match is sent to a
corporate syslog server (policy action).
To effectively use this plugin, you should have a solid understanding of either FTP
server functionality, LDAP server functionality or both functionalities.

 When classifying your network’s hosts based on User Directory, it is

recommended to use the Forescout Data Exchange (DEX) Plugin, due to its
(A) flexible query ability and (B) ability to reduce load on your LDAP servers.

How It Works
The Forescout External Classifier Plugin operates as follows:
1. Based on its configured download frequency, the External Classifier Plugin
retrieves a set of MAC addresses from an external server. The following
methods can be used:
−

Download from an FTP server

−

Query an LDAP server

2. When a CounterACT Appliance resolves the External Classification host
property in a policy rule for a detected host, the Appliance queries the
External Classifier Plugin to determine/assign the applicable classification.
3. The External Classifier Plugin compares host MAC addresses with its set of
retrieved MAC addresses, and makes one of the following assignments:
−

When the host’s MAC address matches a MAC address found in the
retrieved set of MAC addresses, the plugin assigns the corresponding
classification label to the External Classification host property.

−

The plugin resolves the External Classification host property as Unknown
when the host’s MAC address is not found among the retrieved MAC
addresses, or when the host’s MAC address is unknown to the querying
CounterACT Appliance.

4. The Appliance evaluates the policy rule based on the resolved value of the
External Classification host property.
Version 2.3
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Requirements
The plugin requires the following:


Forescout version 8.2.



Files and query results must contain MAC addresses in the following format:
XX:XX:XX:XX:XX:XX
Where X is any one of the following characters: 0-9, A-F (case insensitive).

What to Do
Once you verify that requirements have been met, perform the following:
1. Ensure the following for the data retrieval:
−

You possess the required information to configure the External Classifier
Plugin to retrieve a MAC address set from either FTP server, LDAP server
or both types of servers. See Configure the Plugin.

2. Deploy:
−

Determine the number of CounterACT Appliances at which the plugin must
be configured. See Deployment Considerations.

−

Configure the External Classifier Plugin. See Configure the Plugin.

3. Start the External Classifier Plugin in all your CounterACT Appliances. See
Start the Plugin.

Deployment Considerations
Before configuration, use the following guidelines to determine the number of
CounterACT Appliances in which the plugin must be configured:


If you have one file or one LDAP query that lists all the MAC addresses of a
specific device classification, for example, an FTP file containing the MAC
addresses of all your printers, configure the plugin in one CounterACT
Appliance to classify devices using the one classification.



If you require two different files or two different LDAP queries to
retrieve the MAC addresses of two different device classifications, for
example, an FTP file/LDAP query containing the MAC addresses of all your
printers and another FTP file/LDAP query containing the MAC addresses of all
your surveillance cameras, you must configure the plugin in two different
CounterACT Appliances to classify devices using the two different
classifications.



For n number of different files or different LDAP queries to retrieve the
MAC addresses of n different device classifications, you must configure the
plugin in n different CounterACT Appliances.



A single CounterACT Appliance can handle both an FTP file and an LDAP
query.
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When resolving the External Classification host property for a given host, the policy
engine of the assigned Appliance queries its local plugin. The local plugin must be
running, even though it does not download FTP files or perform LDAP queries,
because the local plugin maintains the information pushed to it by the remote
plugins configured to download/query, which are running on other appliances. By
relying on information supplied from any configured plugins, the assigned Appliance
manages to compile a complete list of the applicable classifications for that host.
Therefore, the External Classifier Plugin must run in all your CounterACT Appliances.

Version 2.3
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Configure the Plugin
Configure the External Classifier Plugin to obtain the set of MAC addresses necessary for its comparison of detected hosts and assigning of the configured text
label - using one or both of the following methods:


Download a file from an FTP server



Query an LDAP server

For guidelines as to the number of CounterACT Appliances in which the plugin must
be configured, see Deployment Considerations.

 When classifying your network’s hosts based on User Directory, it is

recommended to use the Forescout Data Exchange (DEX) Plugin, due to its
(A) flexible query ability and (B) ability to reduce load on your LDAP servers.

To configure the External Classifier Plugin:
1. In the Forescout Console, select Options from the Tools menu. The Options
pane opens.
2. Open the Modules pane and select Core Extensions > External Classifier.
3. Select Configure. The Select Appliances dialog box opens.
4. In the dialog box, select the checkbox of an Appliance to configure and select
OK. The External Classifier Plugin Configuration dialog box opens.

Version 2.3
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5. To configure the plugin for MAC address retrieval using an FTP file download,
select the FTP tab and define the following information:
Field

Description

Classify using
remote file
accessed via
FTP

Select checkbox to assign classification tag based on a MAC
address set provided from an FTP server file

Classification
Tag

Text label assigned to any detected host with a matching MAC
address in the specified FTP file (see table entry Path to File).

FTP Server
Address

IP address of the FTP server from which to download the file.

FTP User Name

Login username for the FTP server. Default is anonymous.

Password

Login password for the FTP server.

Retype
Password

Login password confirmation.

Path to File

Path to the file to download. Provided path must be relative to
the FTP root directory.

Download
Frequency

The period, in minutes, the plugin waits before repeating the
FTP file download.

Selecting this checkbox makes all other fields in this tab
available for editing.

Provided value determines how frequently MAC address
updates, applied in the FTP file, can be available to the plugin
for its use.
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6. To configure the plugin for MAC address retrieval using an LDAP query, select
the LDAP tab.

Define the following information:
Field

Description

Classify using LDAP query

Select checkbox to assign classification tag based on
a MAC address set provided from an LDAP server
query.
Selecting this checkbox makes all other fields in this
tab available for editing.

Version 2.3

Classification Tag

Text label assigned to any detected host with a
matching MAC address in the specified LDAP query
result (see table entry LDAP Query).

LDAP Server
Address/Hostname

Identify the LDAP server to query, by defining this
field as follows:


When using a standard LDAP connection, enter
either the IP address or the fully qualified domain
name (FQDN) of the LDAP server to query.



When using an LDAP over TLS connection, enter
the fully qualified domain name (FQDN) of the
LDAP server to query.

LDAP username

Login username for the LDAP server.

LDAP Password

Login password for the LDAP server.

Retype LDAP Password

Login password confirmation.

LDAP Port

Port the plugin uses with a standard LDAP connection.
By default, this port is 389.

9

Core Extensions Module: External Classifier Plugin

Configuration Guide

Field

Description

Use TLS

Selecting this checkbox instructs the plugin to use a
TLS connection to perform LDAP queries (LDAP over
TLS).
By default, this checkbox is disabled (not selected). If
this checkbox is not selected, the plugin uses a
standard LDAP connection to query the LDAP server.
When this checkbox is selected, the following become
available for configuration:
- LDAP TLS Port
- The Forescout platform's server verifies
LDAP server certificate chain
- Check LDAP server certificate revocation
status
- Additional CDPs for CRL
- Soft-fail OCSP requests

LDAP TLS Port
Authenticate
LDAP Server
Certificate

Port the plugin uses with an LDAP over TLS
connection. By default, this port is 636.
The
Forescout
platform's
server
verifies
LDAP
server
certificate
chain

Selecting this checkbox instructs Forescout eyeSight
to verify the certificate authority trust chain of the
certificate that the LDAP server presents to eyeSight.

Check
LDAP
server
certificate
revocation
status

Instruct Forescout eyeSight to verify/not to verify the
revocation status of the server certificate.

Additional
CDPs for
CRL

By default, this checkbox is disabled (not selected).
To support Forescout eyeSight’s certificate-based
authentication of external servers, use the Console
certificates interface (Options > Certificates) to
configure certificate authority trust chains for
eyeSight's use.

In the field’s drop-down menu, make one of the
following selections:


Do not check (default) – do not verify certificate
revocation status.



Using CRL – consult the Appliance's Certificate
Revocation List (CRL) to verify the revocation
status of the certificate.



Using OCSP – look for an OCSP responder URL in
the certificate and verify the revocation status of
the certificate against the OCSP responder.

Additional CRL distribution points (CDPs).
(Optional) Enter one or more additional URLs from
which Forescout eyeSight downloads additional CRLs
that it uses to verify the revocation status of the
certificate provided by the LDAP server. Use the
comma (,) to separate between multiple URLs.
eyeSight only supports the use of HTTP to download
CRLs.
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Description
Soft-fail
OCSP
requests

Selecting the Soft-fail OCSP Requests option
instructs Forescout eyeSight to accept the provided
server certificate even though eyeSight did not
receive a response from the OCSP responder about
the certificate's revocation status.
By default, this checkbox is disabled (not selected).

LDAP Query

Lookup
Base

Lookup base information to use in the LDAP query.

Lookup
Filter

Lookup filter information to use in LDAP query.

Lookup
Attributes

The LDAP attribute, containing the MAC address, to
use in LDAP query.

LDAP Query Frequency

The period, in minutes, the plugin waits before
repeating the LDAP server query.
Provided value determines how frequently MAC
address updates, applied in the LDAP server, can be
available to the plugin for its use.

7. Select OK. The CounterACT Enterprise Manager Console dialog box opens.
8. Select Yes.

Start the Plugin
After configuring the plugin in the required CounterACT Appliances, you must start
the External Classifier Plugin in all your CounterACT Appliances, even those
Appliances where the plugin is installed but not configured. Running the External
Classifier Plugin in CounterACT Appliances where the plugin is not configured enables
these Appliances to query all configured External Classifier Plugins and resolve the
External Classification host property (assign applicable classifications) for their
assigned hosts.

Ensure That the Component Is Running
After installing the component (and configuring it, if necessary), ensure that it is
running.
To verify:
1. Select Tools > Options > Modules.
2. Navigate to the component and hover over the name to view a tooltip
indicating if it is running on Forescout devices in your deployment. In
addition, next to the component name, you will see one of the following
icons:

Version 2.3

−

- The component is stopped on all Forescout devices.

−

- The component is stopped on some Forescout devices.

−

- The component is running on all Forescout devices.
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3. If the component is not running, select Start, and then select the relevant
Forescout devices.
4. Select OK.

Test the Plugin
Following configuration, test the plugin. Testing verifies the following issues:


Plugin connectivity



Plugin authentication parameters are correct

 Forescout eyeSight expects the operator to verify, using a known device such
as a printer or a scanner, that the classification result assigned to the device
by the plugin is correct.

To test the configured External Classifier Plugin:
1. In the Forescout Console, select Options from the Tools menu. The Options
pane opens.
2. Open the Modules pane, expand Core Extensions, and double-click
External Classifier. The External Classifier-Appliances Installed window
opens and lists all the devices that are installed with the plugin.
3. From the list, select the device you recently configured and select Test. The
CounterACT Enterprise Manager Console dialog box opens.

4. Select Yes. The Testing External Classifier Plugin window opens and displays
the plugin test progress for the selected device.
5. When the window displays the test status Done, select Close.

Version 2.3
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The following figure shows an example of an FTP file for download, containing a set
of MAC addresses:

The following figure shows an example of the plugin test progress of an FTP file
download:
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The following figure shows an example of an LDAP entry with the attribute containing
its MAC address:

The following figure shows an example of the plugin test progress of an LDAP query:
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Use External Classification Information in
Policies
Use the External Classification host property in Forescout policies to detect and
control your network devices. In particular, for your unclassified network devices,
extend Primary Classification and Asset Classification policies by incorporating use of
the External Classification host property into these policies. Refer to the Policy
Management chapter of the Forescout Administration Guide for more information
about creating and updating policies. See Additional Forescout Documentation for
information about how to access the guide.
To work with a policy:
1. Log in to the Forescout Console.
2. Select the Policy tab. The Policy Manager opens.
3. Create or edit a policy.
4. Navigate to the properties list.
5. Select Device Information > External Classification host property.
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15

Core Extensions Module: External Classifier Plugin

Configuration Guide

The following figure shows host detection by sub-rule property match and resulting
action taken:

Display Detected Host Information
View External Classification host property information using one of the following
ways:


Via the Console, All Hosts pane. Display selected host details and expand its
Host tab information.



Generate a Device Details report. Select Reports from the Forescout Console
toolbar. The Reports portal opens. In the Reports portal, either edit an
existing Device Details report or add a new Device Details report. In section
3. Detail, add the table column External Classification property, which is
grouped under Device Information. Run the report or schedule it to be run.
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Core Extensions Module Information
The External Classifier plugin is installed with the Forescout Core Extensions Module.
The Forescout Core Extensions Module provides an extensive range of capabilities
that enhance the core Forescout solution. These capabilities enhance detection,
classification, reporting, troubleshooting, and more. The following components are
installed with the Core Extensions Module:
Advanced Tools Plugin

Device Data Publisher

IoT Posture Assessment
Engine

CEF Plugin

DNS Client Plugin

Cloud Uploader

DNS Enforce Plugin

NBT Scanner Plugin

DHCP Classifier Plugin

DNS Query Extension Plugin

Packet Engine

Dashboards Plugin

External Classifier Plugin

Reports Plugin

Data Publisher

Flow Analyzer Plugin

Syslog Plugin

Data Receiver

Flow Collector

Technical Support Plugin

Device Classification Engine

IOC Scanner Plugin

Web Client Plugin

The Core Extensions Module is a Forescout Base Module. Base Modules are delivered
with each Forescout release. Upgrading the Forescout version or performing a clean
installation installs this module automatically.

Additional Forescout Documentation
For information about other Forescout features and modules, refer to the following
resources:


Documentation Downloads



Documentation Portal



Forescout Help Tools

Documentation Downloads
Documentation downloads can be accessed from the Forescout Technical
Documentation Page, and one of two Forescout portals, depending on which licensing
mode your deployment is using.


Per-Appliance Licensing Mode – Product Updates Portal



Flexx Licensing Mode – Customer Support Portal

 Software downloads are also available from these portals.
To identify your licensing mode:
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Forescout Technical Documentation Page
The Forescout Technical Documentation Page provides access to a searchable, webbased Documentation Portal as well as PDF links to the full range of technical
documentation.
To access the Technical Documentation Page:


Go to https://www.Forescout.com/company/technical-documentation/

Product Updates Portal
The Product Updates Portal provides links to Forescout version releases, Base and
Content Modules, and eyeExtend products, as well as related documentation. The
portal also provides a variety of additional documentation.
To access the Product Updates Portal:


Go to https://updates.forescout.com/support/index.php?url=counteract and
select the version you want to discover.

Customer Support Portal
The Downloads page on the Forescout Customer Support Portal provides links to
purchased Forescout version releases, Base and Content Modules, and eyeExtend
products, as well as related documentation. Software and related documentation will
only appear on the Downloads page if you have a license entitlement for the
software.
To access documentation on the Customer Support Portal:


Go to https://Forescout.force.com/support/ and select Downloads.

Documentation Portal
The Forescout Documentation Portal is a searchable, web-based library containing
information about Forescout tools, features, functionality, and integrations.
To access the Documentation Portal:


Go to https://updates.forescout.com/support/files/counteract/docs_portal/

Forescout Help Tools
Access information directly from the Console.
Console Help Buttons
Use context sensitive Help buttons to quickly access information about the tasks and
topics you are working with.
Forescout Administration Guide


Select Administration Guide from the Help menu.

Plugin Help Files
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After the plugin is installed, select Tools > Options > Modules, select the
plugin and then select Help.

Documentation Portal
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Select Documentation Portal from the Help menu to access the
Documentation Portal.
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